[PATCH-22.03] netifd: bridge: add support option for untagged
Janusz Dziedzic
janusz.dziedzic at gmail.com
Fri Sep 9 00:16:58 PDT 2022
pt., 9 wrz 2022 o 04:32 LiXiong Liu <lxliu at ikuai8.com> napisał(a):
>
> ### swconfig & DSA VLAN Configuration Comparison
> Doesn't just support Tunnk on lan5,
> also need access to 192.168.1.1
> so must setting untagged at br-lan
>
> #switch-vlan
> config switch
> option name 'switch0'
> option reset '1'
> option enable_vlan '1'
>
> config switch_vlan
> option device 'switch0'
> option vlan '0'
> option vid '0'
> option ports '2 3 5 6'
>
> config switch_vlan
> option device 'switch0'
> option vlan '100'
> option vid '100'
> option ports '0 1 4t'
>
>
> #bridge-vlan
> config interface 'lan'
> option device 'br-lan'
> option proto 'static'
> option ipaddr '192.168.1.1'
> option netmask '255.255.255.0'
> option ip6assign '60'
> config device
> option name 'br-lan'
> option type 'bridge'
> list ports 'lan1'
> list ports 'lan2'
> list ports 'lan3'
> list ports 'lan4'
> list ports 'lan5'
>
> config bridge-vlan
> option device 'br-lan'
> option untagged '1'
> option vlan '1'
> list ports 'lan3'
> list ports 'lan4'
> list ports 'lan5'
>
> config bridge-vlan
> option device 'br-lan'
> option vlan '100'
> list ports 'lan1:u*'
> list ports 'lan1:u*'
> list ports 'lan5:t'
>
> #bridge vlan show
> port vlan-id
> lan1 100 PVID Egress Untagged
> lan2 100 PVID Egress Untagged
> lan3 1 PVID Egress Untagged
> lan4 1 PVID Egress Untagged
> lan5 1 PVID Egress Untagged
> 10
> br-lan 1 PVID Egress Untagged
> 10
>
We are using smth like this:
config bridge-vlan 'vlan1'
option name 'vlan1'
option device 'br-lan'
option vlan '1'
option flags 'untagged pvid'
option local '1'
list ports 'eth2:*'
list ports 'eth3:*'
And attached patch - not sure what is best. For sure any option to set
self br config looks good.
BR
Janusz
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 340-br-vlan-self.patch
Type: text/x-patch
Size: 2095 bytes
Desc: not available
URL: <http://lists.openwrt.org/pipermail/openwrt-devel/attachments/20220909/edc4514f/attachment-0001.bin>
More information about the openwrt-devel
mailing list