[OpenWrt-Devel] [PATCH 1/4][ubus] ubusd_event: move strmatch_len to ubus_common.h
Hans Dedecker
dedeckeh at gmail.com
Wed Oct 3 09:36:15 EDT 2018
Rename strmatch_len into ubus_strmatch_len and move it to ubus_common.h
Signed-off-by: Hans Dedecker <dedeckeh at gmail.com>
---
ubus_common.h | 9 +++++++++
ubusd_event.c | 11 +----------
2 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/ubus_common.h b/ubus_common.h
index 4bb9927..5e4d0ad 100644
--- a/ubus_common.h
+++ b/ubus_common.h
@@ -21,4 +21,13 @@
#define ARRAY_SIZE(x) (sizeof(x) / sizeof((x)[0]))
#endif
+static inline bool ubus_strmatch_len(const char *s1, const char *s2, int *len)
+{
+ for (*len = 0; s1[*len] == s2[*len]; (*len)++)
+ if (!s1[*len])
+ return true;
+
+ return false;
+}
+
#endif
diff --git a/ubusd_event.c b/ubusd_event.c
index 0469c20..f07f826 100644
--- a/ubusd_event.c
+++ b/ubusd_event.c
@@ -132,15 +132,6 @@ static void ubusd_send_event_msg(struct ubus_msg_buf **ub, struct ubus_client *c
ubus_msg_send(obj->client, *ub);
}
-static bool strmatch_len(const char *s1, const char *s2, int *len)
-{
- for (*len = 0; s1[*len] == s2[*len]; (*len)++)
- if (!s1[*len])
- return true;
-
- return false;
-}
-
int ubusd_send_event(struct ubus_client *cl, const char *id,
event_fill_cb fill_cb, void *cb_priv)
{
@@ -160,7 +151,7 @@ int ubusd_send_event(struct ubus_client *cl, const char *id,
int cur_match_len;
bool full_match;
- full_match = strmatch_len(id, key, &cur_match_len);
+ full_match = ubus_strmatch_len(id, key, &cur_match_len);
if (cur_match_len < match_len)
break;
--
2.18.0
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel
More information about the openwrt-devel
mailing list