[OpenWrt-Devel] Question for configuring OVS on OpenWRT
Alexandru Ardelean
ardeleanalex at gmail.com
Wed Nov 29 15:48:39 EST 2017
On Wed, Nov 29, 2017 at 1:00 PM, Nam Bong Ha <over3025 at gmail.com> wrote:
> Hi, all
>
> I am using an OpenWRT device that is configured to use ovs.
>
> I want to communicate between wireless devices and wired devices.
> Is the following connection possible?
>
>
> ONOS
> l
> l
> l
> l
> Device1(lan)---------(lan)OpenWRT-OVS(wireless)-------(wireless)Device2
>
>
>
>
> I tried connecting the controller to OpenWRT (ovs).
> However, ssh connection was disconnected at the moment of connection.
>
> root at Controller$ ssh root@[OpenWRT IP]
> root at OpenWrt:~# ovs-vsctl show
> 0ca359f7-74f-420f-b0a5-dfbb6f79
> Bridge br-lan
> Port "eth0.1"
> Interface "eth0.1"
> Port br-lan
> Interface br-lan
> type: internal
I don't know if OVS works with Linux bridges.
In the past it didn't ; it was also recommended to disable the Linux
bridge kmod.
Maybe instead of trying to use br-lan, add all interfaces that are in
the br-lan bridge directly to OVS.
OVS bridges should work just like Linux bridges.
There are some things that are slightly neater with OVS bridges though.
> root at OpenWrt:~# ovs-vsctl set-controller br-lan tcp:[ONOS IP]:6633
>
>
> The following is the configuration file for openwrt.
>
> /etc/config/wireless
> config wifi-device 'radio0'
> option type 'mac80211'
> option macaddr ':ae:99'
> list ht_capab 'LDPC'
> list ht_capab 'SHORT-GI-20'
> list ht_capab 'SHORT-GI-40'
> list ht_capab 'TX-STBC'
> list ht_capab 'RX-STBC1'
> list ht_capab 'DSSS_CCK-40'
> option disabled '0'
> option country 'KR'
> option hwmode '11ng'
> option htmode 'HT20'
> option txpower '11'
> option channel '1'
>
> config wifi-iface
> option device 'radio0'
> option mode 'ap'
> option ssid 'OpenWrt'
> option encryption 'none'
>
>
> /etc/config/network
> config interface 'loopback'
> option ifname 'lo'
> option proto 'static'
> option ipaddr '127.0.0.1'
> option netmask '255.0.0.0'
>
> config interface 'lan'
> option type 'bridge'
> option proto 'static'
> option netmask '255.255.255.0'
> option _orig_ifname 'eth0.1 radio0.network1'
> option _orig_bridge 'true'
> option ipaddr '192.168.30.1'
> option ifname 'eth0.1 tap0 wlan0'
>
> config interface 'wan'
> option ifname 'eth0.2'
> option _orig_ifname 'eth0.2'
> option _orig_bridge 'false'
> option proto 'static'
> option ipaddr '192.168.0.230'
> option netmask '255.255.254.0'
> option gateway '192.168.0.1'
>
> config switch
> option name 'switch0'
> option reset '1'
> option enable_vlan '1'
> option enable_learning '0'
>
> config switch_vlan
> option device 'switch0'
> option vlan '1'
> option ports '0t 2 3 4 5'
> option vid '1'
>
> config switch_vlan
> option device 'switch0'
> option vlan '2'
> option ports '0t 1'
> option vid '2'
>
> Thank you:)
> Have a good day :)
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel at lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
More information about the openwrt-devel
mailing list