[OpenWrt-Devel] Not able to get ipv6 address on OpenWrt ported embedded target
Pratik Prajapati
pratik.prajapati12 at gmail.com
Fri Jul 24 07:16:41 EDT 2015
Hi,
I was trying radvd (2.11) with two machines but my target couldn't assign
ipv6 address.
Setup:
Both machines (linux machine and OpenWrt ported embedded board) are
connected directly with LAN cable.
/etc/radvd.conf
interface eth0 {
AdvSendAdvert on;
MinRtrAdvInterval 3;
MaxRtrAdvInterval 10;
prefix 2001:0db8:0100:f101::/64 {
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
};
};
Started radvd on linux machine: radvd start
ifconfig on host machine:
eth0 Link encap:Ethernet HWaddr 98:90:96:a5:ea:ee
inet6 addr: 2001:db8:100:f101:1920:959d:7aaf:ceef/64 Scope:Global
inet6 addr: fe80::9a90:96ff:fea5:eaee/64 Scope:Link
inet6 addr: 2001:db8:100:f101:9a90:96ff:fea5:eaee/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:8827967 errors:0 dropped:0 overruns:0 frame:0
TX packets:6456033 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:9261325418 (9.2 GB) TX bytes:1780970523 (1.7 GB)
Interrupt:20 Memory:f7c00000-f7c20000
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:11726105 errors:0 dropped:0 overruns:0 frame:0
TX packets:11726105 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:961334966 (961.3 MB) TX bytes:961334966 (961.3 MB)
ifconfig on target:
eth0 Link encap:Ethernet HWaddr E2:AB:C0:A8:5F:38
inet6 addr: fe80::e0ab:c0ff:fea8:5f38/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2474 errors:0 dropped:0 overruns:0 frame:0
TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:277844 (271.3 KiB) TX bytes:10812 (10.5 KiB)
Interrupt:57
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:1601 errors:0 dropped:0 overruns:0 frame:0
TX packets:1601 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:133906 (130.7 KiB) TX bytes:133906 (130.7 KiB)
Network configuration(default) on target:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config globals 'globals'
option ula_prefix 'fdc9:25e1:e731::/48'
radvdump logs on target:
#
# radvd configuration generated by radvdump 2.11
# based on Router Advertisement from fe80::9a90:96ff:fea5:eaee
# received by interface eth0
#
interface eth0
{
AdvSendAdvert on;
# Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
AdvManagedFlag off;
AdvOtherConfigFlag off;
AdvReachableTime 0;
AdvRetransTimer 0;
AdvCurHopLimit 64;
AdvDefaultLifetime 30;
AdvHomeAgentFlag off;
AdvDefaultPreference medium;
AdvSourceLLAddress on;
prefix 2001:db8:100:f101::/64
{
AdvValidLifetime 86400;
AdvPreferredLifetime 14400;
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
}; # End of prefix definition
}; # End of interface definition
#
# radvd configuration generated by radvdump 2.11
# based on Router Advertisement from fe80::9a90:96ff:fea5:eaee
# received by interface eth0
#
interface eth0
{
AdvSendAdvert on;
# Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
AdvManagedFlag off;
AdvOtherConfigFlag off;
AdvReachableTime 0;
AdvRetransTimer 0;
AdvCurHopLimit 64;
AdvDefaultLifetime 30;
AdvHomeAgentFlag off;
AdvDefaultPreference medium;
AdvSourceLLAddress on;
prefix 2001:db8:100:f101::/64
{
AdvValidLifetime 86400;
AdvPreferredLifetime 14400;
AdvOnLink on;
AdvAutonomous on;
AdvRouterAddr on;
}; # End of prefix definition
}; # End of interface definition
My questions:
What other steps needed to get ipv6 address (with prefix sent by radvd on
machine) on target.
Am i missing something in radvd.conf ?
What needs to be changed in openwrt's configuraton (/etc/config/network) on
target side to get ipv6 ?
Thanks,
Pratik
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20150724/e82b7a79/attachment.htm>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
More information about the openwrt-devel
mailing list