[OpenWrt-Devel] [PATCH] base-files: fix generating network configuration
Yousong Zhou
yszhou4tech at gmail.com
Wed Dec 30 09:46:54 EST 2015
On Wednesday, 30 December 2015, Nathan Hintz <nlhintz at hotmail.com> wrote:
> Hi:
> On Dec 30, 2015 4:01 AM, Yousong Zhou <yszhou4tech at gmail.com
> <javascript:_e(%7B%7D,'cvml','yszhou4tech at gmail.com');>> wrote:
> >
> > With the default /e/c/network present, board_detect won't create a new
> > config from board.json. Move this default configuration to
> > generate_static_network of config_generate instead.
> >
> > This should fix the issue on malta target and should not affect other
> > targets that provide its own default network config
> >
> > Signed-off-by: Yousong Zhou <yszhou4tech at gmail.com
> <javascript:_e(%7B%7D,'cvml','yszhou4tech at gmail.com');>>
> > ---
> > package/base-files/files/bin/config_generate | 8 ++++++++
> > package/base-files/files/etc/config/network | 18 ------------------
> > 2 files changed, 8 insertions(+), 18 deletions(-)
> > delete mode 100644 package/base-files/files/etc/config/network
> >
> > diff --git a/package/base-files/files/bin/config_generate
> b/package/base-files/files/bin/config_generate
> > index 9218788..39a0c60 100755
> > --- a/package/base-files/files/bin/config_generate
> > +++ b/package/base-files/files/bin/config_generate
> > @@ -14,6 +14,14 @@ generate_static_network() {
> > set network.loopback.proto='static'
> > set network.loopback.ipaddr='127.0.0.1'
> > set network.loopback.netmask='255.0.0.0'
> > + delete network.lan
> > + network.lan=interface
>
> Should the syntax of these be "set network.lan..."?
>
Indeed~ Thanks for the review.
yousong
> > + network.lan.type='bridge'
> > + network.lan.ifname='eth1'
> > + network.lan.proto='static'
> > + network.lan.ipaddr='192.168.1.1'
> > + network.lan.netmask='255.255.255.0'
> > + network.lan.ip6assign='60'
> > delete network.globals
> > set network.globals='globals'
> > set network.globals.ula_prefix='auto'
> > diff --git a/package/base-files/files/etc/config/network
> b/package/base-files/files/etc/config/network
> > deleted file mode 100644
> > index d3cd3c6..0000000
> > --- a/package/base-files/files/etc/config/network
> > +++ /dev/null
> > @@ -1,18 +0,0 @@
> > -# Copyright (C) 2006 OpenWrt.org
> > -
> > -config interface loopback
> > - option ifname lo
> > - option proto static
> > - option ipaddr 127.0.0.1
> > - option netmask 255.0.0.0
> > -
> > -config interface lan
> > - option ifname eth0
> > - option type bridge
> > - option proto static
> > - option ipaddr 192.168.1.1
> > - option netmask 255.255.255.0
> > - option ip6assign 60
> > -
> > -config globals globals
> > - option ula_prefix auto
> > --
> > 2.6.3
> > _______________________________________________
> > openwrt-devel mailing list
> > openwrt-devel at lists.openwrt.org
> <javascript:_e(%7B%7D,'cvml','openwrt-devel at lists.openwrt.org');>
> > https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
>
--
yousong
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20151230/af4aa729/attachment.htm>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
More information about the openwrt-devel
mailing list